Martus Solutions - East US Rolling outage – Incident details

East US Rolling outage

Resolved
Major outage
Started 18 days agoLasted 40 minutes

Affected

US

Major outage from 7:30 PM to 8:10 PM

Updates
  • Resolved
    UTC
    Resolved

    This incident has been resolved. Rolling outages occurred during platform updates

  • Investigating
    UTC
    Investigating
    We are currently investigating this incident.